Excel i formuła


  • Uczestnik
    Punkty: 986
    raf001 #513136

    No dobra, ale ja mam starą wersję Excela – XP. Na nowszej mogę sprawdzić dopiero jutro. Wchodzisz w „Ustawienia strony/Arkusz/” w sekcji „Drukuj” przy „Błędy komórek jako” wybierasz „Puste”.


  • Uczestnik
    Punkty: 986
    raf001 #615163

    Stworzona potężna tabela z formułą obliczania procentu, w przypadku niewykorzystanych pól pokazuje błąd #DZIELO/0!, to znaczy że w obliczeniu jest błąd. I tak właśnie jest dopóki nie podstawię wartości (nie można podzielić niczego przez nic). Jednak wartości wstawiam co pewien czas, a na wydruku wychodzą i zagęszczają tabele te właśnia komunikaty formuły. W jaki sposób można to ukryć?, – nie usuwając naturalnie formuły. (Doraźne zakrywanie białym polem odpada)


  • Członek
    Punkty: 50
    archiwum #615171

    Wykorzystaj funkcję JEŻELI, np. w komórce A1 jest wartość, a w A2 jest puste, a chcesz dzielić przez A2 to =JEŻELI(A2 „”;A1/A2;0) – wpisuje zero jeżeli A2 jest puste, dzieli jeżeli nie jest puste lub =JEŻELI(A2 „”;A1/A2;0) – jeżeli A2 jest puste, to wstawia 0 Możesz też zrobić tak =JEŻELI(CZY.BŁĄD(A1/A2);”-„;A1/A2)


  • Członek
    Punkty: 50
    archiwum #615173

    Zginęły mi znaczki. Powinno być (A2 jest różne „”; czyli znak miejszości i większości.


  • Uczestnik
    Punkty: 986
    raf001 #615178

    Za podpowiedź dzięki, będę próbował, ale to jest bardziej skomplikowane ponieważ rzecz jest w tym, że obliczam jakim procentem liczby „x” jest liczba „y” (tj. y x 100: x). Wpisuję formułę =B1*100/A1. Z tym, że regułę tą przygotowuję do późniejszego uzupełnienia. Część tabeli jest wypisana, a część czeka na uzupełnienie i w miejscach oczekujących wyświetla się błąd (jest to błąd logiczny bo nie dzieli się nic przez nic). Jak go ukryć, aby na wydruku miejsca nieuzupełnione były puste?


  • Uczestnik
    Punkty: 986
    raf001 #615179

    Przy prostych działaniach (zwykłym dzieleniu – tworzeniu formuł na pustych polach) formuła JEŻELI sprawdza się znakomicie, ale ton ma być obliczanie procentów.


  • Członek
    Punkty: 50
    archiwum #615181

    To, co było napisane wcześniej będzie działać, a jeżeli chcesz mieć „czułość” na jakikolwiek brak, wystarczy skorzystać z prostego mnożenia, czyli zakładając, że w polach A1 i B1 masz wartość, które chcesz sprawdzać: =jeżeli(A1*A2;operacja jaką chcesz dokonać;””) wtedy brak wartość choć w jednym polu będzie dawać „”, czyli pustą komórkę. Jak nadal nie qmasz, podaj konkretne dane (w których polach), a formułkę zaraz zmajstrujemy.


  • Członek
    Punkty: 50
    archiwum #615182

    o, forum znaczki przycina, to zrobimy odwrotnie: =jeżeli(A1*A2=0;””; operacja_wykonania_gdy_oba_pola_niepuste)


  • Członek
    Punkty: 50
    archiwum #615184

    Tak naprawdę nie widzę różnicy pomiędzy zwykłym dzieleniem, a liczeniem procentów. Wpisujesz funkcję JEŻELI sprawdzającą Dzielnik i jeżeli dzielnik nie jest pusty to Twoją formułę, czyli =JEŻELI(A1 jest różne „”;B1*100/A1;””) lub też stosujesz „zwykłe” dzielenie a komórkę formatujesz jako zapis procentowy.


  • Uczestnik
    Punkty: 986
    raf001 #615187

    Według tego co pisał GrzegorzG wykombinowałem takie coś: =JEŻELI(CZY.BŁĄD(B1*100/A1);”-„;B1*100/A1), gdzie B1 i A1 są wartościami z których liczę procent. Pokombinuję jeszcze z pozostałymi podpowiedziami, wyglądają na prostsze. Za wszystkie dziękuję.


  • Uczestnik
    Punkty: 26 486
    teczowy #615200

    a może odwrotnie?: =JEŻELI(A1=””;”0″;(B1*100/A1))


  • Uczestnik
    Punkty: 986
    raf001 #615214

    No to jest też dobre bo zamiast kreski doaje zero, co w moim przypadku bardziej jest odpowiednie. Dzięki

Przeglądasz 12 wpisów - od 1 do 12 (z 12)

Musisz być zalogowany, aby pisać odpowiedzi.