Przejdź na skróty do treści. | Przejdź do nawigacji

Zapamiętaj mnie Przypomnij hasło Rejestracja
Wersja mobilna
Newsletter
Zgłoś uwagę
RSS
Forum
rozwiń
Strona główna Forum Oprogramowanie Programy biurowe Excel i formuła

Excel i formuła


Autor Wiadomość

raf001

Nowicjusz

raf001

Wysłany 22.10.2009, 20:18

Tytuł postu: Excel i formuła

Stworzona potężna tabela z formułą obliczania procentu, w przypadku niewykorzystanych pól pokazuje błąd #DZIELO/0!, to znaczy że w obliczeniu jest błąd. I tak właśnie jest dopóki nie podstawię wartości (nie można podzielić niczego przez nic). Jednak wartości wstawiam co pewien czas, a na wydruku wychodzą i zagęszczają tabele te właśnia komunikaty formuły. W jaki sposób można to ukryć?, - nie usuwając naturalnie formuły.
(Doraźne zakrywanie białym polem odpada)

Grzegor...

Nauczyciel

GrzegorzG

Wysłany 22.10.2009, 21:11

Tytuł postu: RE: Excel i formuła

Wykorzystaj funkcję JEŻELI, np. w komórce A1 jest wartość, a w A2 jest puste, a chcesz dzielić przez A2 to
=JEŻELI(A2 “”;A1/A2;0) - wpisuje zero jeżeli A2 jest puste, dzieli jeżeli nie jest puste
lub
=JEŻELI(A2 “”;A1/A2;0) - jeżeli A2 jest puste, to wstawia 0

Możesz też zrobić tak
=JEŻELI(CZY.BŁĄD(A1/A2);“-”;A1/A2)

Grzegor...

Nauczyciel

GrzegorzG

Wysłany 22.10.2009, 21:14

Tytuł postu: RE: Excel i formuła

Zginęły mi znaczki. Powinno być
(A2 jest różne “”;
czyli znak miejszości i większości.

raf001

Nowicjusz

raf001

Wysłany 22.10.2009, 21:54

Tytuł postu: RE: Excel i formuła

Za podpowiedź dzięki, będę próbował, ale to jest bardziej skomplikowane ponieważ rzecz jest w tym, że obliczam jakim procentem liczby “x” jest liczba “y” (tj. y x 100 : x). Wpisuję formułę =B1*100/A1. Z tym, że regułę tą przygotowuję do późniejszego uzupełnienia. Część tabeli jest wypisana, a część czeka na uzupełnienie i w miejscach oczekujących wyświetla się błąd (jest to błąd logiczny bo nie dzieli się nic przez nic). Jak go ukryć, aby na wydruku miejsca nieuzupełnione były puste?

raf001

Nowicjusz

raf001

Wysłany 22.10.2009, 22:02

Tytuł postu: RE: Excel i formuła

Przy prostych działaniach (zwykłym dzieleniu - tworzeniu formuł na pustych polach) formuła JEŻELI sprawdza się znakomicie, ale ton ma być obliczanie procentów.

smola

Student

smola

Wysłany 22.10.2009, 22:21

Tytuł postu: RE: Excel i formuła

raf001
Przy prostych działaniach (zwykłym dzieleniu - tworzeniu formuł na pustych polach) formuła JEŻELI sprawdza się znakomicie, ale ton ma być obliczanie procentów.

To, co było napisane wcześniej będzie działać, a jeżeli chcesz mieć “czułość” na jakikolwiek brak, wystarczy skorzystać z prostego mnożenia, czyli zakładając, że w polach A1 i B1 masz wartość, które chcesz sprawdzać: =jeżeli(A1*A2 ;operacja jaką chcesz dokonać;“”)
wtedy brak wartość choć w jednym polu będzie dawać “”, czyli pustą komórkę.

Jak nadal nie qmasz, podaj konkretne dane (w których polach), a formułkę zaraz zmajstrujemy.

smola

Student

smola

Wysłany 22.10.2009, 22:24

Tytuł postu: RE: Excel i formuła

o, forum znaczki przycina , to zrobimy odwrotnie: =jeżeli(A1*A2=0;“”; operacja_wykonania_gdy_oba_pola_niepuste)

Grzegor...

Nauczyciel

GrzegorzG

Wysłany 22.10.2009, 22:29

Tytuł postu: RE: Excel i formuła

Tak naprawdę nie widzę różnicy pomiędzy zwykłym dzieleniem, a liczeniem procentów. Wpisujesz funkcję JEŻELI sprawdzającą Dzielnik i jeżeli dzielnik nie jest pusty to Twoją formułę, czyli
=JEŻELI(A1 jest różne “”;B1*100/A1;“”)
lub też stosujesz “zwykłe” dzielenie a komórkę formatujesz jako zapis procentowy.

Grzegor...

Nauczyciel

GrzegorzG

Wysłany 22.10.2009, 22:32

Tytuł postu: RE: Excel i formuła

No dobra, ale ja mam starą wersję Excela - XP. Na nowszej mogę sprawdzić dopiero jutro. Wchodzisz w “Ustawienia strony/Arkusz/” w sekcji “Drukuj” przy “Błędy komórek jako” wybierasz “Puste”.

raf001

Nowicjusz

raf001

Wysłany 22.10.2009, 22:45

Tytuł postu: RE: Excel i formuła

Według tego co pisał GrzegorzG wykombinowałem takie coś:
=JEŻELI(CZY.BŁĄD(B1*100/A1);“-”;B1*100/A1), gdzie B1 i A1 są wartościami z których liczę procent. Pokombinuję jeszcze z pozostałymi podpowiedziami, wyglądają na prostsze.
Za wszystkie dziękuję.

teczowy

Profesor

teczowy

Wysłany 23.10.2009, 02:20

Tytuł postu: RE: Excel i formuła

a może odwrotnie?:
=JEŻELI(A1=“”;“0”;(B1*100/A1))

raf001

Nowicjusz

raf001

Wysłany 23.10.2009, 12:44

Tytuł postu: RE: Excel i formuła

No to jest też dobre bo zamiast kreski doaje zero, co w moim przypadku bardziej jest odpowiednie. Dzięki
CENEO Kup najtaniej
Geniatech ATV310B Geniatech ATV310B
Dostępny w 1 sklepach
Sprawdź CENY tego produktu
Toshiba Satellite C855-23Z 16GB (PSCBYE-048017PL-16) Toshiba Satellite C855-23Z 16GB (PSCBYE-048017PL-16)
Dostępny w 3 sklepach
Sprawdź CENY tego produktu
Amica 58GE2.33HZpP(W) Amica 58GE2.33HZpP(W)
Dostępny w 38 sklepach
Sprawdź CENY tego produktu
Hp Probook 450 G1 (E9Y37Ea) Hp Probook 450 G1 (E9Y37Ea)
Dostępny w 4 sklepach
Sprawdź CENY tego produktu
Video
nowe filmy